Waves Warning

New Mac OS software upgrade not supported      16/03/07

Waves Warning


Buying Choices
Apple’s lastest upgrade (10.4.9) to their operating system has been made available this week but Waves are warning users of their plug-ins not to install it until further notice.They say that Mac OS 10.4.9 is not supported and causes Waves plug-ins to malfunction.
More information:



More Videos

Featured Video
Arturia MiniBrute 2 

See it in action

Meet The Makers: Vlad Kreimer Of Soma Laboratory 

Oragnismic manufacturing explained


Sonic LAB: Behringer Neutron Analog Desktop Semi Modular Review 

How good can a $300 synth sound?


Friday Fun: Arturia Minibrute 2 and Ventris Dual Reverb 

Ambient jam with frozen verbs


Meet The Makers - Chris Randall of Audio Damage 

Plug-ins, roots and the journey